Degraded Email Query Performance
Resolved·Degraded performance

The issues affecting email queries and notifications have been fully resolved. All systems are operating normally. We apologize for any inconvenience and thank you for your patience.

Sat, Dec 6, 2025, 04:01 AM
(3 days ago)
·
Affected components
Email
Updates

Resolved

The issues affecting email queries and notifications have been fully resolved. All systems are operating normally. We apologize for any inconvenience and thank you for your patience.

Sat, Dec 6, 2025, 04:01 AM

Monitoring

The previously reported email query issues have been patched. Users may still not receive email-based notifications and automations at this time. Our team is actively investigating.

Fri, Dec 5, 2025, 09:06 PM(6 hours earlier)

Monitoring

Email queries may be slow or fail intermittently. Investigation in progress.

Fri, Dec 5, 2025, 06:47 PM(2 hours earlier)