We're currently experiencing issues with composing & sending emails
Resolved·Degraded performance

The issues composing and sending emails have been fully resolved. All email systems are now operating normally. We apologize for any inconvenience and thank you for your patience.

Mon, Dec 8, 2025, 09:14 PM
(1 day ago)
·
Affected components
Email
Updates

Resolved

The issues composing and sending emails have been fully resolved. All email systems are now operating normally. We apologize for any inconvenience and thank you for your patience.

Mon, Dec 8, 2025, 09:14 PM

Monitoring

Composing and sending emails may be slow or fail intermittently. We've identified the issue and are working on a resolution.

Mon, Dec 8, 2025, 08:27 PM(46 minutes earlier)