Resolved
All email functionality restored.
Resolved
All email functionality restored.
Investigating
Email forwarding, attachments, and labelling may be slow or fail intermittently for a subset of users. We are investigating and working on a resolution.